<!DOCTYPE html>
<!--[if lt IE 7 ]> <html lang="en-US" class="ie6"><![endif]-->
<!--[if IE 7 ]>    <html lang="en-US" class="ie7"><![endif]-->
<!--[if IE 8 ]>    <html lang="en-US" class="ie8"><![endif]-->
<!--[if IE 9 ]>    <html lang="en-US" class="ie9"><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html lang="en-US"><!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://linoxide.com/xmlrpc.php">
<!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<title>Echo Command in Linux with Examples</title>

<meta name="description" content="This tutorial shows how to use echo commands in linux with examples. Echo command displays text which is passed as arguments on the terminal." />
<link rel="canonical" href="https://linoxide.com/linux-command/echo-command-in-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Echo Command in Linux with Examples" />
<meta property="og:description" content="This tutorial shows how to use echo commands in linux with examples. Echo command displays text which is passed as arguments on the terminal." />
<meta property="og:url" content="https://linoxide.com/linux-command/echo-command-in-linux/" />
<meta property="og:site_name" content="LinOxide" />
<meta property="article:author" content="https://www.facebook.com/jakiarie" />
<meta property="article:tag" content="Linux Commands" />
<meta property="article:section" content="LINUX COMMANDS" />
<meta property="article:published_time" content="2019-08-21T00:54:51+00:00" />
<meta property="article:modified_time" content="2019-08-21T12:31:41+00:00" />
<meta property="og:updated_time" content="2019-08-21T12:31:41+00:00" />
<meta property="og:image" content="https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg" />
<meta property="og:image:secure_url" content="https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg" />
<meta property="og:image:width" content="713" />
<meta property="og:image:height" content="341" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://linoxide.com/#organization","name":"","url":"https://linoxide.com/","sameAs":[]},{"@type":"WebSite","@id":"https://linoxide.com/#website","url":"https://linoxide.com/","name":"LinOxide","publisher":{"@id":"https://linoxide.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://linoxide.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://linoxide.com/linux-command/echo-command-in-linux/#webpage","url":"https://linoxide.com/linux-command/echo-command-in-linux/","inLanguage":"en-US","name":"Echo Command in Linux with Examples","isPartOf":{"@id":"https://linoxide.com/#website"},"image":{"@type":"ImageObject","@id":"https://linoxide.com/linux-command/echo-command-in-linux/#primaryimage","url":"https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg","width":713,"height":341},"primaryImageOfPage":{"@id":"https://linoxide.com/linux-command/echo-command-in-linux/#primaryimage"},"datePublished":"2019-08-21T00:54:51+00:00","dateModified":"2019-08-21T12:31:41+00:00","description":"This tutorial shows how to use echo commands in linux with examples. Echo command displays text which is passed as arguments on the terminal."},{"@type":"Article","@id":"https://linoxide.com/linux-command/echo-command-in-linux/#article","isPartOf":{"@id":"https://linoxide.com/linux-command/echo-command-in-linux/#webpage"},"author":{"@id":"https://linoxide.com/author/arthurj/#author"},"headline":"Echo Command in Linux with Examples","datePublished":"2019-08-21T00:54:51+00:00","dateModified":"2019-08-21T12:31:41+00:00","commentCount":0,"mainEntityOfPage":"https://linoxide.com/linux-command/echo-command-in-linux/#webpage","publisher":{"@id":"https://linoxide.com/#organization"},"image":{"@id":"https://linoxide.com/linux-command/echo-command-in-linux/#primaryimage"},"keywords":"Linux Commands","articleSection":"LINUX COMMANDS"},{"@type":["Person"],"@id":"https://linoxide.com/author/arthurj/#author","name":"Jamie Arthur","description":"James is a passionate Linux and Windows Systems Administrator with 4 years of experience in Linux, databases and Front-End development. He loves doing research on different Linux distributions and experimenting with installation and configuration of different services and features. His hobbies include swimming, reading novels and playing video games.","sameAs":["https://www.facebook.com/jakiarie","https://www.linkedin.com/in/james-kiarie-78733968/","https://twitter.com/https://twitter.com/jay_kiarie"]}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; Feed" href="https://linoxide.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; Comments Feed" href="https://linoxide.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; Echo Command in Linux with Examples Comments Feed" href="https://linoxide.com/linux-command/echo-command-in-linux/feed/" />
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://linoxide.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='main-style-css' href='https://linoxide.com/wp-content/plugins/category-post-list-widget/css/main.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='slick-style-css' href='https://linoxide.com/wp-content/plugins/category-post-list-widget/css/slick.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='slick-theme-css' href='https://linoxide.com/wp-content/plugins/category-post-list-widget/css/slick-theme.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='color-bg-tag-cloud-css' href='https://linoxide.com/wp-content/plugins/color-bg-tag-cloud/inc/color-bg-tag-cloud.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='easy_author_image-css' href='https://linoxide.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://linoxide.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/pagenavi-css.css?ver=2.70' media='all' />
<link rel='stylesheet' id='ez-icomoon-css' href='https://linoxide.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=1.7' media='all' />
<link rel='stylesheet' id='ez-toc-css' href='https://linoxide.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=1.7' media='all' />
<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 600;}div#ez-toc-container ul li {font-size: 100%;}div#ez-toc-container {background: #ffffff;border: 1px solid #1e73be;width: 100%;}div#ez-toc-container p.ez-toc-title {color: #000000;}div#ez-toc-container ul.ez-toc-list a {color: #428bca;}div#ez-toc-container ul.ez-toc-list a:hover {color: #2a6496;}div#ez-toc-container ul.ez-toc-list a:visited {color: #428bca;}
</style>
<link rel='stylesheet' id='font-awesome-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/fonts/font-awesome/css/font-awesome.min.css?ver=4.4.0' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/bootstrap.min.css?ver=3.3.1' media='all' />
<link rel='stylesheet' id='flexslider-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/flexslider.css?ver=2.6.1' media='all' />
<link rel='stylesheet' id='theme-shortcodes-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/shortcodes.css?ver=2.6.1' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='default-google-fonts-css' href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A300%2C400%2C600%2C700%2C300italic%2C400italic%2C600italic%2C700italic%7CPT+Serif%3A400%2C700%2C400italic%2C700italic&#038;ver=2.6.1' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://linoxide.com/wp-includes/css/dashicons.min.css?ver=5.2.1' media='all' />
<link rel='stylesheet' id='theme-print_styles-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/style-print.css?ver=2.6.1' media='print' />
<link rel='stylesheet' id='theme-main-styles-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/style.css?ver=2.6.1' media='all' />
<link rel='stylesheet' id='theme-custom_styles-css' href='https://linoxide.com/wp-content/themes/wp-prosperity/style-custom.css?ver=2.6.1' media='all' />
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css' href='https://linoxide.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=6.5.0' media='all' />
<link rel='stylesheet' id='scss-css' href='https://linoxide.com/wp-content/cache/busting/1/sccss.css?ver=1564837697' media='all' />
<script src='https://linoxide.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://linoxide.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1' defer></script>
<script src='https://linoxide.com/wp-content/plugins/category-post-list-widget/js/slick.min.js?ver=5.2.1' defer></script>
<script>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/linoxide.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"22588","token":"ef2c082f4c","debug":""};
/* ]]> */
</script>
<script src='https://linoxide.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2' defer></script>
<link rel='https://api.w.org/' href='https://linoxide.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linoxide.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linoxide.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.2.1" />
<link rel='shortlink' href='https://linoxide.com/?p=22588' />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<style>
.site-container, .unboxed .site-inner, .unboxed .wrap { max-width:1280px; }
.unboxed .slideslider .flex-caption-wrap { max-width:1280px !important; }
.site-header .wrap { height:140px;}
h1.site-title, .site-title { font-family:PT Serif;font-style:normal;font-weight:normal;font-size:24px;text-transform:none; }
h1,h2,h3,h4,h5,h6 { font-family:PT Serif;font-style:normal;font-weight:normal;text-transform:none; }
h2.widgettitle, h2.widget-title {font-size:18px;}
h1 {font-size:30px;}
h2 {font-size:28px;}
h3 {font-size:26px;}
h4 {font-size:24px;}
h5 {font-size:20px;}
h6 {font-size:18px;}
body { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:16px;line-height:1.5;text-transform:none; }
.site-inner .sidebar { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:14px;line-height:1.5;text-transform:none; }
.nav-primary { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:14px;text-transform:none; }
.nav-secondary { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:14px;text-transform:none; }
.nav-fixed { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:14px;text-transform:none; }
.comment-metadata,.wp-caption,.wp-caption-text,.entry-caption,.gallery-caption,.entry-media .thumb-caption,.sitemap-entry-meta,.entry-meta { font-family:Source Sans Pro;font-style:normal;font-weight:normal;font-size:14px;text-transform:none; }
.site-container { border: 0; }
.site-container { border-color:#000000; }
#footer-widgets { background-color:#ffffff; }
#footer-widgets h1, #footer-widgets h2, footer-widgets h3, #footer-widgets h4, #footer-widgets h5, #footer-widgets h6 { color:#ffffff !important; }
#footer-widgets h2.widgettitle, #footer-widgets h2.widgettitle a { color:#ffffff !important; }
  .site-branding {
    margin-top: 30px !important;
}


  .fl.newsdesc a {
    line-height: 0 !important;
}
.fl.newsdesc h2 {
    margin: 0;
}

.search-button{
  vertical-align: top !important;
    padding-top: 10px !important;
}
@media only screen and (min-width: 961px) {
#secnav{
    
    vertical-align: top;
    font-size: 16px;
}
nav.nav-secondary{
    height:30px !important;
}
.subicons.site-icons {
    position: relative;
    margin-bottom: -3%;
        width: 20%;
}
.site-inner, .wrap {
    padding: 0 15px;
}

#category_post_list_widget-5 
.widgettitle , #category_post_list_widget-4 .widgettitle , #text-19 .widgettitle ,.widget_color_bg_tag_cloud .widgettitle {
    font-size: 16px !important;
    font-weight: 600 !important;
    text-transform: uppercase;
    margin-bottom: 6px  !important;
    background: none repeat scroll 0 0 #12b7d5 !important;
    text-align: center;
    padding: 10px;
    border-bottom: none;
}

#text-19 form {
    
    background: #194357;
    border-radius: 11px;
}

.fl.newsdesc {
    border-bottom: 1px solid #cfc7c7;
    margin-bottom: 10px;
}

.fl.newsdesc p:last-child {
    margin-bottom:0;
    margin-bottom: 10px;
}

.widget_category_post_list_widget .post_content {
    border-bottom: transparent;
}
.fl.newsdesc h2 a {
    font-size: 16px !important;
    margin: 0 !important;
    color: #777 !important;
    font-family: 'Open Sans' !important;
    font-weight: normal !important;
    line-height: normal !important;
}
}
</style>
<link rel="amphtml" href="https://linoxide.com/linux-command/echo-command-in-linux/amp/"><link rel="icon" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" sizes="32x32" />
<link rel="icon" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" />
<meta name="msapplication-TileImage" content="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" />
<style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-22588 single-format-standard c-sw two-column unboxed nav-arrows " itemscope="itemscope" itemtype="http://schema.org/WebPage">

<div class="site-container">

<header class="site-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="wrap">
<div class="linoxideLogoTitle" itemprop="headline">
<a href="https://linoxide.com/" title="LinOxide" rel="home">LinOxide</a>
</div>

<nav class="nav-secondary" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="wrap">
<span title="Display Menu" class="menu-toggle">
<i class="fa fa-navicon"></i>
</span>
<ul id="secnav" class="nav-menu"><li id="menu-item-18206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18206"><a href="https://linoxide.com/about/">ABOUT</a></li>
<li id="menu-item-3855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3855"><a href="https://linoxide.com/category/linux-how-to/">LINUX HOWTO</a></li>
<li id="menu-item-10470" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10470"><a href="https://linoxide.com/category/linux-command/">LINUX COMMANDS</a></li>
<li id="menu-item-14789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14789"><a href="https://linoxide.com/category/tools/">LINUX TOOLS</a></li>
<li id="menu-item-21245" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-21245"><a href="https://linoxide.com/linux-how-to/linux-commands-brief-outline-examples/">A-Z LINUX COMMANDS</a></li>
</ul>
</div>
</nav>

</div>
</header>


<div class="site-inner">
<div class="site-inner-wrap">
<div class="tb-col-border narrow"></div>
<div class="tb-col-border wide"></div>

<div id="primary" class="content-area">

<main id="content" class="site-content" itemprop="mainContentOfPage">
<div itemscope="itemscope" itemtype="http://schema.org/Blog">
<article id="post-22588" class="post-22588 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-command tag-command linux-command" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost">
<div class="entry-wrap">
<div class="entry-container ccc">
<header class="entry-header">
<h1 class="entry-title" itemprop="headline">
<span>
Echo Command in Linux with Examples </span>
</h1>
<div class="entry-meta"><span class="date"><i class="fa fa-clock-o"></i><time class="entry-date" itemprop="datePublished" datetime="2019-08-21T01:54:51+01:00">August 21, 2019</time></span><span>Updated August 21, 2019</span><span class="categories-links"><i class="fa fa-folder-open"></i><a href="https://linoxide.com/category/linux-command/" rel="category tag">LINUX COMMANDS</a></span></div> 
</header>
<div class="entry-content" itemprop="text">
<p><img class="aligncenter size-full wp-image-22740" src="https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg" alt="echo command in linux" width="713" height="341" srcset="https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg 713w, https://linoxide.com/wp-content/uploads/2019/07/echo-command-300x143.jpg 300w, https://linoxide.com/wp-content/uploads/2019/07/echo-command-190x91.jpg 190w" sizes="(max-width: 713px) 100vw, 713px" /></p><div class='code-block code-block-2 ai-viewport-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1494089593353074" data-ad-slot="8003513341"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Echo is a Unix/Linux command tool used for displaying lines of text or string which are passed as arguments on the command line. This is one of the <a href="https://linoxide.com/linux-command/essential-linux-basic-commands/" target="_blank" rel="noopener noreferrer">basic command in linux</a> and most commonly used in shell scripts. In this tutorial, we will look at the different  options of echo command.</p>
<p><strong>Basic Syntax</strong></p>
<p>echo [option] [string]
<h2>1) Displaying a string on the terminal</h2>
<p>To print text or a string on the terminal, use the syntax</p>
<p><strong>echo [string]</strong></p><div class='code-block code-block-8 ai-viewport-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1494089593353074" data-ad-slot="7965761027"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<pre>$ echo "Welcome to Linux"</pre>
<p>Sample Output</p>
<pre>Welcome to Linux
</pre>
<h2>2) Declare a variable and echo it value</h2>
<p>Assume you have a variable x which is assigned the value 45  i.e.</p>
<pre>$ x=10</pre>
<p>You can print the value of variable x by executing the command</p>
<pre>$ echo The value of x is $x</pre>
<p>Sample Output</p>
<pre>The value of x is 10</pre>
<h2>3) Remove  Spaces in between text using -e and \b options</h2>
<p>You can choose to remove spaces using the <strong>\b</strong> option in conjunction with the <strong>-e</strong> parameter.</p>
<p><strong>NOTE:</strong></p>
<p>The -e parameter is used for the interpretation of backslash interpreters</p>
<p>Let's assume you have the text string</p>
<pre>Linux is an opensource operating system</pre>
<p>To remove spaces between the words, run</p>
<pre>$ echo -e "Linux \bis \ban \bopensource \boperating \bsystem"
</pre>
<p>Sample Output</p>
<pre>Linuxisanopensourceoperatingsystem</pre>
<h2>4) Create new lines in between text  using \n option</h2>
<p>To create a new line after each word in a string use the<strong> -e</strong> operator  with the<strong> \n</strong> option  as shown</p>
<pre>$ echo -e "Linux \nis \nan \nopensource \noperating \nsystem"</pre>
<p><strong>Sample Output</strong></p>
<pre>Linux 
is 
an 
opensource 
operating 
system</pre>
<h2>5) Create horizontal tab space in between text  using \t option</h2>
<p>If you want to create tab spaces in between words in  a string use the  <strong>-e</strong> operator  with the<strong> \t</strong> option  as shown</p>
<pre>$ echo -e "Linux \tis \tan \topensource \toperating \tsystem"</pre>
<p>Sample Output</p>
<pre>Linux is an opensource operating system</pre>
<h2>5) Create vertical tab spaces using the \v option</h2>
<p>You can decide to get a bit fancy and create vertical tab spaces using the <strong>-e</strong> operator  with the<strong> \v </strong>option  as shown</p>
<pre>$ echo -e "Linux \vis \van \vopensource \voperating \vsystem"</pre>
<p>Sample Output</p>
<pre>Linux 
       is 
           an 
               opensource 
                          operating 
                                     system</pre>
<h2>6) Double vertical tab using \n and \v option simultaneously</h2>
<p>You can double the vertical tab spacing as shown below using the <strong>\n</strong> and <strong>\v</strong> options as shown</p>
<pre>$ echo -e "Linux \n\vis \n\van \n\vopensource \n\voperating \n\vsystem"</pre>
<p>Sample Output</p>
<pre>Linux

is

an

opensource

operating

system

</pre>
<h2>7) Print all files and folders using the * option</h2>
<p>You can print all files and folders in your <a href="https://linoxide.com/linux-command/linux-pwd-command/" target="_blank" rel="noopener noreferrer">current working directory</a> using the command</p>
<pre>$ echo *</pre>
<p>This has the same output as the <a href="https://linoxide.com/linux-command/20-ls-command-linux/" target="_blank" rel="noopener noreferrer">ls command</a></p>
<p>Sample Output</p>
<p><img class="size-full wp-image-22604 aligncenter" src="https://linoxide.com/wp-content/uploads/2019/07/print-all-files-and-folders.png" alt="print all files and folders with echo command" width="811" height="65" srcset="https://linoxide.com/wp-content/uploads/2019/07/print-all-files-and-folders.png 811w, https://linoxide.com/wp-content/uploads/2019/07/print-all-files-and-folders-300x24.png 300w, https://linoxide.com/wp-content/uploads/2019/07/print-all-files-and-folders-768x62.png 768w, https://linoxide.com/wp-content/uploads/2019/07/print-all-files-and-folders-190x15.png 190w" sizes="(max-width: 811px) 100vw, 811px" /></p>
<p>To print files of  a specific type run</p>
<pre>$ echo *.file_extension</pre>
<p>For example</p>
<pre>$ echo *.pdf</pre>
<p>Sample Output</p>
<p><img class="size-full wp-image-22606 aligncenter" src="https://linoxide.com/wp-content/uploads/2019/07/print-specific-file-types.png" alt="print specific file types" width="366" height="50" srcset="https://linoxide.com/wp-content/uploads/2019/07/print-specific-file-types.png 366w, https://linoxide.com/wp-content/uploads/2019/07/print-specific-file-types-300x41.png 300w, https://linoxide.com/wp-content/uploads/2019/07/print-specific-file-types-190x26.png 190w" sizes="(max-width: 366px) 100vw, 366px" /></p>
<h2>8) Using the carriage return '\r' option</h2>
<p>The 'r' option gives you the carriage return i.e. any word(s) before the \r are omitted in the output</p>
<pre>$ echo -e "Linux \r is an opensource operating system"</pre>
<p>Sample Output</p>
<pre>is an opensource operating system</pre>
<h2>9) Omit echoing trailing newline</h2>
<p>The <strong>-n </strong>option is used for omitting trailing newline. This is shown in the example below</p>
<pre>$ echo -n "Linux is an opensource operating system"</pre>
<p>Sample Output</p>
<pre>Linux is an opensource operating <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="becdc7cdcadbd3d4dfd3dbcdfedccbcdcadbcc">[email&#160;protected]</a>:/$</pre>
<h2>Conclusion</h2>
<p>In this tutorial we learned how to use echo command in linux with few examples. Feel free to try out the command and also weigh in on your feedback. Thank you.</p>
</div>
</div> 
<div class="rv_hentry">
<span class="vcard author"><span class="fn">Jamie Arthur</span></span>
<span class="date updated published">1:54 am</span>
</div>
<footer class="entry-footer">
<div id="sharelinks" class="share-icons">
<h6>SHARE ON</h6>
<a data-toggle="tooltip" title="Share this Entry on Facebook" rel="external" class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://linoxide.com/?p=22588"><i class="fa fa-facebook"></i>Facebook</a><a data-toggle="tooltip" title="Share this Entry on Google+" rel="external" class="googleplus" href="https://plus.google.com/share?url=https://linoxide.com/?p=22588"><i class="fa fa-google-plus"></i>Google+</a><a data-toggle="tooltip" title="Tweet this Entry on Twitter" rel="external" class="twitter" href="https://twitter.com/home?status=Echo+Command+in+Linux+with+Examples:https://linoxide.com/?p=22588"><i class="fa fa-twitter"></i>Twitter</a><a data-toggle="tooltip" title="Pin this Entry on Pinterest" rel="external" class="pinterest" href="https://pinterest.com/pin/create/button/?url=https://linoxide.com/?p=22588&amp;media=https://linoxide.com/wp-content/uploads/2019/07/echo-command.jpg"><i class="fa fa-pinterest"></i>Pinterest</a><a data-toggle="tooltip" title="Share this Entry on LinkedIn" rel="external" class="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://linoxide.com/?p=22588&amp;title=Echo+Command+in+Linux+with+Examples"><i class="fa fa-linkedin"></i>LinkedIn</a><a data-toggle="tooltip" title="Share this on Reddit" rel="external" class="reddit" href="https://reddit.com/submit?url=https://linoxide.com/?p=22588&amp;title=Echo+Command+in+Linux+with+Examples"><i class="fa fa-reddit"></i>Reddit</a>
</div>
<div class="entry-meta"><span class="tags-links"><i class="fa fa-tag"></i><a href="https://linoxide.com/tag/command/" rel="tag">Linux Commands</a></span><meta itemprop="image" content="https://linoxide.com/wp-content/themes/wp-prosperity/bg18.jpg"></div>
<div class="author-info ">
<h3 class="author-title">About Jamie Arthur</h3>
<img alt="" src="https://linoxide.com/wp-content/uploads/2017/11/Jamie-Arthur.jpg" srcset="https://linoxide.com/wp-content/uploads/2017/11/Jamie-Arthur.jpg" class="avatar avatar-120 photo" height="120" width="120">
<div class="author-description" itemprop="description">
<p class="author-bio">
James is a passionate Linux and Windows Systems Administrator with 4 years of experience in Linux, databases and Front-End development. He loves doing research on different Linux distributions and experimenting with installation and configuration of different services and features. His hobbies include swimming, reading novels and playing video games. </p>
</div>
<div class="subicons author-icons">
<a data-toggle="tooltip" class="subicon rss" rel="external" title="Jamie Arthur&#039;s RSS Feed" href="https://linoxide.com/author/arthurj/feed/"><i class="fa fa-rss"></i></a><a data-toggle="tooltip" class="subicon twitter" rel="external" title="Jamie Arthur on Twitter" href="https://twitter.com/jay_kiarie"><i class="fa fa-twitter"></i></a><a data-toggle="tooltip" class="subicon facebook" rel="external" title="Jamie Arthur on Facebook" href="https://www.facebook.com/jakiarie"><i class="fa fa-facebook"></i></a><a data-toggle="tooltip" class="subicon linkedin" rel="external" title="Jamie Arthur on LinkedIn" href="https://www.linkedin.com/in/james-kiarie-78733968/"><i class="fa fa-linkedin"></i></a>
</div>
<a class="author-archive-link" href="https://linoxide.com/author/arthurj/">Author's All Posts</a>
<div style="font-size:22px; color:#ff6600;">Like to become part of <a target="_blank" href="/linoxide-team/">Linoxide Team</a> and contribute tips? <a href="/contact-us/" target="_blank">Contact us here.</a> </div>
</div>
<div class="tb-related-posts"><h3 class="related-title">Hand-picked related articles</h3><div class="related-wrap"> <div class="relpost">
<a class="post-thumbnail medium" href="https://linoxide.com/linux-command/use-ip-command-linux/">
<img width="181" height="266" src="https://linoxide.com/wp-content/uploads/2014/05/Linux-Nettools-vs-Iproute2.png" class="medium-thumbnail wp-post-image" alt="Net tools vs Iproute2" srcset="https://linoxide.com/wp-content/uploads/2014/05/Linux-Nettools-vs-Iproute2.png 2575w, https://linoxide.com/wp-content/uploads/2014/05/Linux-Nettools-vs-Iproute2-204x300.png 204w, https://linoxide.com/wp-content/uploads/2014/05/Linux-Nettools-vs-Iproute2-697x1024.png 697w" sizes="(max-width: 181px) 100vw, 181px" /> </a>
<div class="rel-title-excerpt">
<a class="rel-title" href="https://linoxide.com/linux-command/use-ip-command-linux/" title="How to use IP Command in Linux with Examples">How to use IP Command in Linux with Examples</a>
<div class="rel-excerpt"><p>The linux ip command is similar to ifconfig, but more powerful and is intended to be a replacement for it. With ip you have the advantage of performing several network administration tasks with only one command. ifconfig is one of the [...]</p>
</div>
</div>
</div>
<div class="relpost">
<a class="post-thumbnail medium" href="https://linoxide.com/linux-command/examples-linux-shutdown-commands/">
<img class="wp-post-image medium-thumbnail" src="https://linoxide.com/wp-content/themes/wp-prosperity/images/rel-default.jpg" alt="4 Commands to Shutdown Linux from Terminal" itemprop="image" />
</a>
<div class="rel-title-excerpt">
<a class="rel-title" href="https://linoxide.com/linux-command/examples-linux-shutdown-commands/" title="4 Commands to Shutdown Linux from Terminal">4 Commands to Shutdown Linux from Terminal</a>
<div class="rel-excerpt"><p>How can you shut down your system successfully using a command? According to the manual page of shutdown command, shutting down a system means bringing the system down in a secure way. This article discusses the commands you can use [...]</p>
</div>
</div>
</div>
<div class="relpost">
<a class="post-thumbnail medium" href="https://linoxide.com/linux-command/linux-dmesg-command/">
<img width="400" height="91" src="https://linoxide.com/wp-content/uploads/2013/12/dmesg_chrome_error.png" class="medium-thumbnail wp-post-image" alt="dmesg chrome error" srcset="https://linoxide.com/wp-content/uploads/2013/12/dmesg_chrome_error.png 724w, https://linoxide.com/wp-content/uploads/2013/12/dmesg_chrome_error-300x67.png 300w" sizes="(max-width: 400px) 100vw, 400px" /> </a>
<div class="rel-title-excerpt">
<a class="rel-title" href="https://linoxide.com/linux-command/linux-dmesg-command/" title="11 Linux dmesg Commands to Print Kernel Ring Buffer">11 Linux dmesg Commands to Print Kernel Ring Buffer</a>
<div class="rel-excerpt"><p>Sometimes we underestimate the existence of logs. For the system administrator logs are important. From the log, we can analyze what causes an error. dmesg is a command that print kernel messages into your screen. Dmesg print its data by reading [...]</p>
</div>
</div>
</div>
</div></div>
<div class='google-ads-content' style='display:none;'><h3 class="related-title">Suggested Articles</h3><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display: inline-block; width: 100%; height: 400px;" data-ad-client="ca-pub-1494089593353074" data-ad-slot="2060232545"></ins>
<script>
		(adsbygoogle = window.adsbygoogle || []).push({});
		</script></div>
</footer>
</div> 
<script>
								jQuery(function($){
                                        
                                       /* $("#bottom-ads-content").css({"width":$(".site-inner").width()});
                                        $(window).resize(function(){
                                        	    $("#bottom-ads-content").css({"width":$(".site-inner").width()})
                                        })*/
								})
							</script> </article>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Comments <small><a rel="nofollow" id="cancel-comment-reply-link" href="/linux-command/echo-command-in-linux/#respond" style="display:none;">Cancel Comment</a></small></h3> <form action="https://linoxide.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-author"><span class="genericon genericon-user"></span><input id="author" placeholder="Name *" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><span class="genericon genericon-mail"></span><input id="email" placeholder="Email *" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-comment"><textarea placeholder="" id="comment" name="comment" cols="45" rows="3" aria-required="true"></textarea></p>
<p id="commentquiz" style="clear:both">
All comments are subject to moderation.<br>
<label for="quiz">What is linoxide based on ? Windows or Linux ? Type your answer into the box </label><input type="text" name="quiz" id="quiz" size="22" tabindex="4" value="" />
</p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Your Comment" /> <input type='hidden' name='comment_post_ID' value='22588' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p> </form>
</div>
<div id="comments" class="entry-comments">
</div></div>
</main>
</div>

<div id="secondary" class="sidebar-area">

<aside class="sidebar sidebar-wide-top" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><form class="linoxideSearchWidget" itemprop="potentialAction" itemscope="" itemtype="https://schema.org/SearchAction" method="get" action="https://linoxide.com/" role="search"><meta itemprop="target" content="https://linoxide.com/?s={s}"><input itemprop="query-input" type="search" name="s" id="linoxideSearchInput" placeholder="Search Linoxide Tutorials"><input type="submit" value="Search"></form></div></div></section><section id="text-20" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-1494089593353074" data-ad-slot="9479741343"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div></section><section id="recent-posts-widget-with-thumbnails-2" class="widget recent-posts-widget-with-thumbnails"><div class="widget-wrap"><div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
<h2 class="widget-title widgettitle">Latest Giveaways!</h2> <ul>
<li><a href="https://linoxide.com/linux-how-to/append-to-end-of-file-in-linux/" target="_blank"><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2019/06/append-end-file-linux-190x91.png" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2019/06/append-end-file-linux-190x91.png 190w, https://linoxide.com/wp-content/uploads/2019/06/append-end-file-linux-300x143.png 300w, https://linoxide.com/wp-content/uploads/2019/06/append-end-file-linux.png 713w" sizes="(max-width: 190px) 100vw, 190px" /><span class="rpwwt-post-title">How to Append to End of a File in Linux</span></a></li>
<li><a href="https://linoxide.com/linux-how-to/install-google-chrome-on-debian/" target="_blank"><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2019/07/install-chrome-debian-190x91.jpg" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2019/07/install-chrome-debian-190x91.jpg 190w, https://linoxide.com/wp-content/uploads/2019/07/install-chrome-debian-300x143.jpg 300w, https://linoxide.com/wp-content/uploads/2019/07/install-chrome-debian.jpg 713w" sizes="(max-width: 190px) 100vw, 190px" /><span class="rpwwt-post-title">How to Install Google Chrome on Debian</span></a></li>
<li><a href="https://linoxide.com/linux-how-to/add-user-to-sudoers-on-debian/" target="_blank"><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2019/07/add-user-sudoers-debian-190x91.jpg" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2019/07/add-user-sudoers-debian-190x91.jpg 190w, https://linoxide.com/wp-content/uploads/2019/07/add-user-sudoers-debian-300x143.jpg 300w, https://linoxide.com/wp-content/uploads/2019/07/add-user-sudoers-debian.jpg 713w" sizes="(max-width: 190px) 100vw, 190px" /><span class="rpwwt-post-title">How to Add a User to Sudoers on Debian</span></a></li>
</ul>
</div>
</div></section><section id="text-28" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-1494089593353074" data-ad-slot="2401512540"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div></section><section id="text-27" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><div style="color: #fff; background: #F7BA08; font-size: 18px; padding: 8px;">           Linux Commands Cheat Sheet<a style="color: #194357; width: 100%; display: block; text-align: center; text-decoration: underline; font-size: 18px;" href="https://linoxide.com/linux-command/linux-commands-cheat-sheet/" target="_blank" rel="noopener noreferrer">Download PDF Version</a></div>
</div>
</div></section><section id="text-26" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><div style="color: #fff; background: #f60; font-size: 18px; padding: 8px;">Beginners Kubernetes Practical Guide<br />
<a style="color: #194357; width: 100%; display: block; text-align: center; text-decoration: underline; font-size: 18px;" href="https://linoxide.com/ebooks/learn-kubernetes-basics-beginners-guide-online/" target="_blank" rel="noopener noreferrer">Download Your Free Ebook</a></div>
</div>
</div></section><section id="text-23" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><form class="subscribe-box" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow">
<div class="textwidget">
<div class="feedwidgetdiv">
<h4>Enjoyed the Read?</h4>
<p>Don’t miss our next article!</p>
<div><input name="email" required="required" type="email" placeholder="Enter Your Email *" /><input class="feedsubmit" type="submit" value="Subscribe" /><input name="uri" type="hidden" value="linoxideblog" /><input name="loc" type="hidden" value="en_US" /></div>
<p>100% privacy &#8211; We will never spam you</p>
</div>
</div>
</form>
</div>
</div></section><section id="text-2" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-1494089593353074" data-ad-slot="6247073342"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div></section><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget">
<script language="javascript" src="https://live.sekindo.com/live/liveView.php?s=99693&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed13c7kqgviytw&subId=[SUBID_ENCODED]"></script>
</div></div></section> </aside>
<aside style="display:none !important;">
<h3 class="recent_post_heading">Suggested Read</h3>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:1057px" data-ad-client="ca-pub-1494089593353074" data-ad-slot="2060232545"></ins>
<script>
                    (adsbygoogle = window.adsbygoogle || []).push({});
                    </script>
 </aside>
</div>
</div>
</div>

<div class="banner-ad ad-above-footer" style="background-color:#ffffff">
<div class="wrap">
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-47319559-1', 'auto');
  ga('send', 'pageview');

</script>
</div>
</div>


<div id="footer-widgets">
<div class="wrap">
<div class="row">

<aside class="sidebar col-md-4 footer-widgets-left">
</aside>

<aside class="sidebar col-md-4 footer-widgets-center">
<section id="socialicons-widget-2" class="widget socialicons"><div class="widget-wrap"><h2 class="widget-title widgettitle">Join Our 16.9K Linux Community</h2>
<div class="textwidget dark square">
<div class="subicons site-icons">
<a data-toggle="tooltip" data-placement="bottom" class="subicon rss" rel="external" title="RSS Feed" href="https://linoxide.com/feed/"><i class="fa fa-rss"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon twitter" rel="external" title="Connect on Twitter" href="https://twitter.com/LinOxide"><i class="fa fa-twitter"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon facebook" rel="external" title="Connect on Facebook" href="https://www.facebook.com/Linoxide"><i class="fa fa-facebook"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon pinterest" rel="external" title="Connect on Pinterest" href="https://www.pinterest.com.au/LinOxide/"><i class="fa fa-pinterest"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon youtube" rel="external" title="Connect on Youtube" href="https://www.youtube.com/channel/UC9y60e21PnE5xmc0PfcKgjw"><i class="fa fa-youtube-play"></i></a>
</div></div></div></section><section id="text-25" class="widget widget_text"><div class="widget-wrap"> <div class="textwidget"><p style="font-size: 16px; text-align: center;">Ask &amp; Share &#8211; <a target="_blank" style="text-decoration:underline; color: #12b7d5!important; text-align: center;" href="https://www.facebook.com/groups/LinuxPenguinChatGroup/" rel="noopener noreferrer">Join Our Facebook Community</a></p>
</div>
</div></section> </aside>

<aside class="sidebar col-md-4 footer-widgets-right">
<section id="text-19" class="widget widget_text"><div class="widget-wrap"><h2 class="widget-title widgettitle">SUBSCRIBE TO FREE NEWSLETTER</h2> <div class="textwidget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow">
<div class="textwidget">
<div class="feedwidgetdiv">
<h4>Enjoyed the Read?</h4>
<p>Don’t miss our next article!</p>
<div style="text-align: center;"><input name="email" required="required" type="email" placeholder="Enter Your Email *" /> <input class="feedsubmit" type="submit" value="Subscribe" /> <input name="uri" type="hidden" value="linoxideblog" /> <input name="loc" type="hidden" value="en_US" /></div>
<p style="margin-bottom: 0px;">100% privacy &#8211; We will never spam you</p>
</div>
</div>
</form>
</div>
</div></section> </aside>
</div>
</div>
</div>

<footer class="site-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="wrap">
<div class="subicons site-icons">
<a data-toggle="tooltip" data-placement="bottom" class="subicon rss" rel="external" title="RSS Feed" href="https://linoxide.com/feed/"><i class="fa fa-rss"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon twitter" rel="external" title="Connect on Twitter" href="https://twitter.com/LinOxide"><i class="fa fa-twitter"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon facebook" rel="external" title="Connect on Facebook" href="https://www.facebook.com/Linoxide"><i class="fa fa-facebook"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon pinterest" rel="external" title="Connect on Pinterest" href="https://www.pinterest.com.au/LinOxide/"><i class="fa fa-pinterest"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon youtube" rel="external" title="Connect on Youtube" href="https://www.youtube.com/channel/UC9y60e21PnE5xmc0PfcKgjw"><i class="fa fa-youtube-play"></i></a>
</div><ul id="footernav" class="footer-nav-menu"><li id="menu-item-16860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16860"><a href="https://linoxide.com/tos/">Terms of Service</a></li>
<li id="menu-item-16861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16861"><a href="https://linoxide.com/privacy-policy/">PRIVACY</a></li>
<li id="menu-item-16862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16862"><a href="https://linoxide.com/contact-us/">CONTACT</a></li>
</ul>
<div class="site-info hasnav">
Copyright © 2019 BTreme. All rights reserved </div>
</div>
</footer>
</div>
<style>
	        .entry-meta span.author  span {
	        	  margin-right:0;
	        }
		    #category_post_list_widget-5
		    .widgettitle, #category_post_list_widget-4 .widgettitle, #text-16 .widgettitle, .widget_color_bg_tag_cloud .widgettitle{
		         background: #12b7d5!important;
		             font-size: 16px !important;
				    font-weight: 600 !important;
				    text-transform: uppercase;
				    margin-bottom: 6px !important;

				    text-align: center;
				    padding: 10px;
				    border-bottom: none;

		   }

		  #footer-widgets .post_content {
		   	      border:none;
		   }
		   .fl.newsdesc {
			    border-bottom: 1px solid #cfc7c7;
			    margin-bottom: 10px;
			}
		   #text-16 form {
			    background: #194357;
			    border-radius: 11px;
			}
		 body .fl.newsdesc h2 a:hover{
		 	color:#000!important;
		 }
	  </style>
<script src='https://linoxide.com/wp-includes/js/comment-reply.min.js?ver=5.2.1' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/bootstrap.min.js?ver=3.3.1' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/plugins.js?ver=2.6.1' defer></script>
<script src='https://linoxide.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/jquery.isotope.min.js?ver=5.26' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/jquery.infinitescroll.min.js?ver=2.0b2.120519' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/manual-trigger.js?ver=2.0b2.110617' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/jquery.isotope.sloppy-masonry.min.js?ver=2.6.1' defer></script>
<script src='https://linoxide.com/wp-content/themes/wp-prosperity/js/functions.js?ver=2.6.1' defer></script>
<script src='https://linoxide.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9' defer></script>
<script>
            window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);
        </script><script data-no-minify="1" async src="https://linoxide.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script>
<div id="backtotop"><i class="fa fa-angle-up fa-lg"></i></div>
</body>
</html>
