<!DOCTYPE html> <!--[if lt IE 7 ]><html lang="en-US" class="ie6"><![endif]--> <!--[if IE 7 ]><html lang="en-US" class="ie7"><![endif]--> <!--[if IE 8 ]><html lang="en-US" class="ie8"><![endif]--> <!--[if IE 9 ]><html lang="en-US" class="ie9"><![endif]--> <!--[if (gt IE 9)|!(IE)]><!--><html lang="en-US"><!--<![endif]--><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="preload" href="https://linoxide.com/wp-content/themes/wp-prosperity/fonts/et-line.woff" as="font" type="font/woff" crossorigin><link rel="preload" href="https://linoxide.com/wp-content/themes/wp-prosperity/fonts/font-awesome/fonts/fontawesome-webfont.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://linoxide.com/wp-content/omgf-webfonts/Roboto-400-normal-4mxK.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://linoxide.com/wp-content/omgf-webfonts/Roboto-300-normal-BBc4.woff2" as="font" type="font/woff2" crossorigin><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://linoxide.com/xmlrpc.php"> <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]--><style id="aoatfcss" media="all">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</style><link rel="preload" as="style" media="all" href="https://linoxide.com/wp-content/cache/autoptimize/css/autoptimize_efd83d0d9f9fdda84ab81aeaf9348a45.css" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" as="style" media="print" href="https://linoxide.com/wp-content/cache/autoptimize/css/autoptimize_03eef3b02dfc1583d5243c4a9db1e181.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="https://linoxide.com/wp-content/cache/autoptimize/css/autoptimize_efd83d0d9f9fdda84ab81aeaf9348a45.css" rel="stylesheet" /><link media="print" href="https://linoxide.com/wp-content/cache/autoptimize/css/autoptimize_03eef3b02dfc1583d5243c4a9db1e181.css" rel="stylesheet" /></noscript><title>How to Remove Linux User from a Group</title><meta name="description" content="This tutorial shows how to remove a user from a group in Linux. Learn two methods and also manually remove the user from the group."/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://linoxide.com/linux-how-to/remove-linux-user-from-group/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Remove Linux User from a Group" /><meta property="og:description" content="This tutorial shows how to remove a user from a group in Linux. Learn two methods and also manually remove the user from the group." /><meta property="og:url" content="https://linoxide.com/linux-how-to/remove-linux-user-from-group/" /><meta property="og:site_name" content="LinOxide" /><meta property="article:author" content="m.facebook.com/slax81" /><meta property="article:tag" content="Linux Commands" /><meta property="article:section" content="LINUX HOWTO" /><meta property="article:published_time" content="2020-03-31T10:00:39+00:00" /><meta property="article:modified_time" content="2020-03-31T10:08:40+00:00" /><meta property="og:updated_time" content="2020-03-31T10:08:40+00:00" /><meta property="og:image" content="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png" /><meta property="og:image:secure_url" content="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png" /><meta property="og:image:width" content="713" /><meta property="og:image:height" content="341" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://linoxide.com/#website","url":"https://linoxide.com/","name":"LinOxide","description":"Linux / Open Source Online Resources","potentialAction":{"@type":"SearchAction","target":"https://linoxide.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://linoxide.com/linux-how-to/remove-linux-user-from-group/#primaryimage","url":"https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png","width":713,"height":341},{"@type":"WebPage","@id":"https://linoxide.com/linux-how-to/remove-linux-user-from-group/#webpage","url":"https://linoxide.com/linux-how-to/remove-linux-user-from-group/","inLanguage":"en-US","name":"How to Remove Linux User from a Group","isPartOf":{"@id":"https://linoxide.com/#website"},"primaryImageOfPage":{"@id":"https://linoxide.com/linux-how-to/remove-linux-user-from-group/#primaryimage"},"datePublished":"2020-03-31T10:00:39+00:00","dateModified":"2020-03-31T10:08:40+00:00","author":{"@id":"https://linoxide.com/#/schema/person/82ccc78835d1d0d43b9b6ce71b67377f"},"description":"This tutorial shows how to remove a user from a group in Linux. Learn two methods and also manually remove the user from the group."},{"@type":["Person"],"@id":"https://linoxide.com/#/schema/person/82ccc78835d1d0d43b9b6ce71b67377f","name":"Slavisa Milojkovic","description":"Slavi\u0161a is a long time Linux user and system administrator. He was PCLinuxOS Gnome distribution developer and maintainer for several years and active opensource supporter.","sameAs":["m.facebook.com/slax81","https://twitter.com/https://twitter.com/pclos_lxgator"]}]}</script> <link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; Feed" href="https://linoxide.com/feed/" /><link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; Comments Feed" href="https://linoxide.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="LinOxide &raquo; How to Remove Linux User from a Group Comments Feed" href="https://linoxide.com/linux-how-to/remove-linux-user-from-group/feed/" /><style id='ez-toc-inline-css'>div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 600;}div#ez-toc-container ul li {font-size: 100%;}div#ez-toc-container {background: #ffffff;border: 1px solid #1e73be;width: 100%;}div#ez-toc-container p.ez-toc-title {color: #000000;}div#ez-toc-container ul.ez-toc-list a {color: #428bca;}div#ez-toc-container ul.ez-toc-list a:hover {color: #2a6496;}div#ez-toc-container ul.ez-toc-list a:visited {color: #428bca;}</style><noscript></noscript><style id='rocket-lazyload-inline-css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://linoxide.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style><link rel='https://api.w.org/' href='https://linoxide.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linoxide.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linoxide.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://linoxide.com/?p=23754' /><link rel="alternate" type="application/json+oembed" href="https://linoxide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinoxide.com%2Flinux-how-to%2Fremove-linux-user-from-group%2F" /><link rel="alternate" type="text/xml+oembed" href="https://linoxide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinoxide.com%2Flinux-how-to%2Fremove-linux-user-from-group%2F&#038;format=xml" /><meta name="viewport" content="width=device-width, initial-scale=1" /> <style>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</style><link rel="amphtml" href="https://linoxide.com/linux-how-to/remove-linux-user-from-group/amp/"><link rel="icon" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" sizes="32x32" /><link rel="icon" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" /><meta name="msapplication-TileImage" content="https://linoxide.com/wp-content/uploads/2018/01/linoxide-logo-amp.png" /><style id="wp-custom-css">.entry-content > * {margin-top:20px!important;margin-bottom:20px!important;}
.entry-content > *:first-child {margin-top:0!important;}
.entry-content > *:last-child {margin-bottom:0!important;}
.entry-content p>img {margin-top:0!important;margin-bottom:0!important}
#secnav a:hover {text-decoration:none}</style><style>.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head><body class="post-template-default single single-post postid-23754 single-format-standard c-sw two-column unboxed nav-arrows " itemscope="itemscope" itemtype="http://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="linoxideLogoTitle" itemprop="headline"> <a href="https://linoxide.com/" title="LinOxide" rel="home">LinOxide</a></div><nav class="nav-secondary" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"> <span title="Display Menu" class="menu-toggle"> <i class="fa fa-navicon"></i> </span><ul id="secnav" class="nav-menu"><li id="menu-item-18206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18206"><a href="https://linoxide.com/about/">ABOUT</a></li><li id="menu-item-3855" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3855"><a href="https://linoxide.com/category/linux-how-to/">LINUX HOWTO</a></li><li id="menu-item-10470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10470"><a href="https://linoxide.com/category/linux-command/">LINUX COMMANDS</a></li><li id="menu-item-14789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14789"><a href="https://linoxide.com/category/tools/">LINUX TOOLS</a></li><li id="menu-item-21245" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-21245"><a href="https://linoxide.com/linux-how-to/linux-commands-brief-outline-examples/">A-Z LINUX COMMANDS</a></li></ul></div></nav></div></header><div class="site-inner"><div class="site-inner-wrap"><div class="tb-col-border narrow"></div><div class="tb-col-border wide"></div><div id="primary" class="content-area"><main id="content" class="site-content" itemprop="mainContentOfPage"><div itemscope="itemscope" itemtype="http://schema.org/Blog"><article id="post-23754" class="post-23754 post type-post status-publish format-standard has-post-thumbnail hentry category-linux-how-to tag-command linux-how-to" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><div class="entry-wrap"><div class="entry-container ccc"><header class="entry-header"><h1 class="entry-title" itemprop="headline"> <span> How to Remove Linux User from a Group </span></h1><div class="entry-meta"><span class="date"><i class="fa fa-clock-o"></i><time class="entry-date" itemprop="datePublished" datetime="2020-03-31T11:00:39+01:00">March 31, 2020</time></span><span>Updated March 31, 2020</span><span class="author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a class="entry-author-link" href="https://linoxide.com/author/slavisam/" title="View all posts by Slavisa Milojkovic" itemprop="url" rel="author"><span itemprop="name">Slavisa Milojkovic</span></a></span><span class="categories-links"><i class="fa fa-folder-open"></i><a href="https://linoxide.com/category/linux-how-to/" rel="category tag">LINUX HOWTO</a></span></div></header><div class="entry-content" itemprop="text"><p><img class="aligncenter size-full wp-image-23876" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20713%20341'%3E%3C/svg%3E" alt="how to remove user from a group in linux" width="713" height="341" data-lazy-srcset="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png 713w, https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group-190x91.png 190w" data-lazy-sizes="(max-width: 713px) 100vw, 713px" data-lazy-src="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png" /><noscript><img class="aligncenter size-full wp-image-23876" src="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png" alt="how to remove user from a group in linux" width="713" height="341" srcset="https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png 713w, https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group-190x91.png 190w" sizes="(max-width: 713px) 100vw, 713px" /></noscript></p><p>A user can be a member of one primary and one or several secondary (supplementary) groups in Linux. The file '/etc/group' defines group membership for each user in the Linux system.</p><p>In this tutorial, we will learn how to remove a user from a group in Linux. We will use two methods and also I will show how to manually remove the user from the group by deleting from '/etc/group' file.</p><div class='code-block code-block-2 ai-viewport-2 ai-viewport-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1494089593353074" data-ad-slot="8003513341" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><h3>Create Linux User</h3><p>For the purpose of this tutorial, we will create a user named 'testuser'. When a new user is created, a new primary group with the same name for that user is created too.</p><p>We will <a href="https://linoxide.com/linux-command/linux-user-add-command/" target="_blank" rel="noopener noreferrer">create a new user</a> by issuing the following command:</p><div class='code-block code-block-8 ai-viewport-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-1494089593353074" data-ad-slot="7965761027"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><pre>$ sudo useradd -m testuser
</pre><p>Now we can create a password for that user:</p><pre>$ sudo passwd testuser
Changing password for user testuser.
New password: 
BAD PASSWORD: The password contains the user name in some form
Retype new password: 
passwd: all authentication tokens updated successfully.
</pre><p>I used the same password as the username so I got a warning that the password shouldn't contain the user name in some form.</p><h3><span style="font-family: Georgia, 'Times New Roman', 'Bitstream Charter', Times, serif;">Adding a User to a Group<br /> </span></h3><p>First, we will create two new groups using <a href="https://linoxide.com/linux-command/groupadd-command/" target="_blank" rel="noopener noreferrer">groupadd command</a> as follows:</p><pre>$ sudo groupadd testgroup1
$ sudo groupadd testgroup2</pre><p>Now we will add 'testuser' user to the above created two groups and also add to 'root' group using the following commands:</p><pre>$ sudo usermod -a -G root testuser
$ sudo usermod -a -G testgroup1 testuser
$ sudo usermod -a -G testgroup2 testuser
</pre><p>Ok, so now if we look at '/etc/group' file and can see that 'testuser' is a member of all three groups.</p><pre>$ cat /etc/group
root:x:0:testuser
.............
testuser:x:1001:
testgroup1:x:1002:testuser
testgroup2:x:1003:testuser
</pre><h3>Find out the Groups a User belongs</h3><p>We can also use two alternative ways to check to which groups does a user belong as follows</p><pre>$ groups testuser
testuser : testuser testgroup1 testgroup2 root

$ id -nG testuser
testuser testgroup1 testgroup2 root
</pre><p>As you can see the output is very similar and those commands accomplish the same thing.</p><h2>Removing User from a Group Using usermod</h2><p>We can remove a user from a group or several groups at once using usermod command. Using usermod you have to specify in which secondary groups you want to keep the user in. Let me explain with an example.</p><pre>$ groups testuser
testuser : testuser testgroup1 testgroup2 root</pre><p>In order to remove user 'testuser' from 'testgroup1' and 'testgroup2' group run the below command ( ie leave testuser only in 'root' group and it's primary 'testuser' group):</p><pre>$ sudo usermod -G root testuser</pre><pre>Results
$ groups testuser
testuser : testuser root</pre><p>So in order to keep a user in more groups, you'll need to mention group names separated by comma (,) like:</p><pre>$ sudo usermod -G root,testgroup1 testuser</pre><pre>Results
# groups testuser
testuser : testuser root testgroup1
</pre><h2>Removing User from a Group Using gpasswd</h2><p>Another command that accomplishes similar results is gpasswd. We use this command to remove users from specified groups, unlike with usermod.<br /> To remove a user from one specific group we can use gpasswd command:</p><pre>$ sudo gpasswd -d testuser root
Removing user testuser from group root

$ groups testuser
testuser : testuser testgroup1 testgroup2

$ sudo gpasswd -d testuser testgroup1
Removing user testuser from group testgroup1

$ groups testuser
testuser : testuser testgroup2
</pre><h2>Removing User from a Group (Manually)</h2><p>We can also remove a user from a group by manually editing the file '/etc/group'. The effects of this method will apply to the user upon reboot.</p><p>You can use your favourite text editor to edit the '/etc/group' file:</p><pre>$ cat /etc/group
.............
sssd:x:993:
sshd:x:74:
chrony:x:992:
vagrant:x:1000:
slocate:x:21:
vboxsf:x:991:
testuser:x:1001:
testgroup1:x:1002:testuser
testgroup2:x:1003:testuser

$ groups testuser
testuser : testuser testgroup1 testgroup2 root
</pre><p>We will now manually edit the last two entries to delete testuser and remove it from testgroup1 and testgroup2 (edited file should look like this):</p><pre>$ cat /etc/group
.............
sssd:x:993:
sshd:x:74:
chrony:x:992:
vagrant:x:1000:
slocate:x:21:
vboxsf:x:991:
testuser:x:1001:
testgroup1:x:1002:
testgroup2:x:1003:
</pre><p>Changes will take place after reboot, and now the user has been removed from those two groups:</p><pre>$ groups testuser
testuser : testuser root
</pre><h2>Conclusion</h2><p>In this tutorial, we have learned how to remove a user from a group using usermod, gpasswd and also by manually deleting them from '/etc/group' file.</p><p>These instructions can be used on any Linux system like Ubuntu, CentOS, Fedora and many others. If you have any questions, please let us know in the comments below.</p></div></div><div class="rv_hentry"> <span class="vcard author"><span class="fn">Slavisa Milojkovic</span></span> <span class="date updated published">11:00 am</span></div><footer class="entry-footer"><div id="sharelinks" class="share-icons"><h6>SHARE ON</h6> <a data-toggle="tooltip" title="Share this Entry on Facebook" rel="external" class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://linoxide.com/?p=23754"><i class="fa fa-facebook"></i>Facebook</a><a data-toggle="tooltip" title="Tweet this Entry on Twitter" rel="external" class="twitter" href="https://twitter.com/home?status=How+to+Remove+Linux+User+from+a+Group:https://linoxide.com/?p=23754"><i class="fa fa-twitter"></i>Twitter</a><a data-toggle="tooltip" title="Pin this Entry on Pinterest" rel="external" class="pinterest" href="https://pinterest.com/pin/create/button/?url=https://linoxide.com/?p=23754&amp;media=https://linoxide.com/wp-content/uploads/2020/02/linux-remove-user-from-group.png"><i class="fa fa-pinterest"></i>Pinterest</a><a data-toggle="tooltip" title="Share this Entry on LinkedIn" rel="external" class="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://linoxide.com/?p=23754&amp;title=How+to+Remove+Linux+User+from+a+Group"><i class="fa fa-linkedin"></i>LinkedIn</a><a data-toggle="tooltip" title="Share this on Reddit" rel="external" class="reddit" href="https://reddit.com/submit?url=https://linoxide.com/?p=23754&amp;title=How+to+Remove+Linux+User+from+a+Group"><i class="fa fa-reddit"></i>Reddit</a></div><div class="entry-meta"><span class="tags-links"><i class="fa fa-tag"></i><a href="https://linoxide.com/tag/command/" rel="tag">Linux Commands</a></span><meta itemprop="image" content="https://linoxide.com/wp-content/themes/wp-prosperity/bg18.jpg"></div><div class="tb-related-posts"><h3 class="related-title">Related Articles</h3><div class="related-wrap"><div class="relpost"><div class="rel-title-excerpt"> <a class="rel-title" href="https://linoxide.com/tools/setup-itop-centos-7/" title="How to Setup iTOP (IT Operational Portal) on CentOS 7">How to Setup iTOP (IT Operational Portal) on CentOS 7</a></div> <a class="post-thumbnail medium" href="https://linoxide.com/tools/setup-itop-centos-7/"> <img width="400" height="266" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20266'%3E%3C/svg%3E" class="medium-thumbnail wp-post-image" alt="itop welcome note" data-lazy-srcset="https://linoxide.com/wp-content/uploads/2015/07/20-400x266.png 400w, https://linoxide.com/wp-content/uploads/2015/07/20-740x493.png 740w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://linoxide.com/wp-content/uploads/2015/07/20-400x266.png" /><noscript><img width="400" height="266" src="https://linoxide.com/wp-content/uploads/2015/07/20-400x266.png" class="medium-thumbnail wp-post-image" alt="itop welcome note" srcset="https://linoxide.com/wp-content/uploads/2015/07/20-400x266.png 400w, https://linoxide.com/wp-content/uploads/2015/07/20-740x493.png 740w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> </a></div><div class="relpost"><div class="rel-title-excerpt"> <a class="rel-title" href="https://linoxide.com/linux-how-to/install-flask-python-ubuntu/" title="How to Install Flask with Python 3 on Ubuntu 18.04">How to Install Flask with Python 3 on Ubuntu 18.04</a></div> <a class="post-thumbnail medium" href="https://linoxide.com/linux-how-to/install-flask-python-ubuntu/"> <img width="400" height="266" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20266'%3E%3C/svg%3E" class="medium-thumbnail wp-post-image" alt="Install Flask Python ubuntu" data-lazy-src="https://linoxide.com/wp-content/uploads/2018/07/Install-Flask-Python-ubuntu-400x266.png" /><noscript><img width="400" height="266" src="https://linoxide.com/wp-content/uploads/2018/07/Install-Flask-Python-ubuntu-400x266.png" class="medium-thumbnail wp-post-image" alt="Install Flask Python ubuntu" /></noscript> </a></div><div class="relpost"><div class="rel-title-excerpt"> <a class="rel-title" href="https://linoxide.com/linux-how-to/setup-log-rotation-logrotate-ubuntu/" title="How to Setup Log Rotation with Logrotate on Ubuntu 18.04">How to Setup Log Rotation with Logrotate on Ubuntu 18.04</a></div> <a class="post-thumbnail medium" href="https://linoxide.com/linux-how-to/setup-log-rotation-logrotate-ubuntu/"> <img width="400" height="266" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20266'%3E%3C/svg%3E" class="medium-thumbnail wp-post-image" alt="logrotate ubuntu" data-lazy-src="https://linoxide.com/wp-content/uploads/2018/05/logrotate-400x266.png" /><noscript><img width="400" height="266" src="https://linoxide.com/wp-content/uploads/2018/05/logrotate-400x266.png" class="medium-thumbnail wp-post-image" alt="logrotate ubuntu" /></noscript> </a></div></div></div></footer></div></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Comments <small><a rel="nofollow" id="cancel-comment-reply-link" href="/linux-how-to/remove-linux-user-from-group/#respond" style="display:none;">Cancel Comment</a></small></h3><form action="https://linoxide.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-author"><span class="genericon genericon-user"></span><input id="author" placeholder="Name *" name="author" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-email"><span class="genericon genericon-mail"></span><input id="email" placeholder="Email *" name="email" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-comment"><textarea placeholder="" id="comment" name="comment" cols="45" rows="3" aria-required="true"></textarea></p><p id="commentquiz" style="clear:both"> All comments are subject to moderation.<br> <label for="quiz">What is linoxide based on ? Windows or Linux ? Type your answer into the box </label><input type="text" name="quiz" id="quiz" size="22" tabindex="4" value="" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Your Comment" /> <input type='hidden' name='comment_post_ID' value='23754' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><div class="wantispam-required-fields"><input type="hidden" name="wantispam_t" class="wantispam-control wantispam-control-t" value="1585820197" /><div class="wantispam-group wantispam-group-q" style="clear: both;"> <label>Current ye@r <span class="required">*</span></label> <input type="hidden" name="wantispam_a" class="wantispam-control wantispam-control-a" value="2020" /> <input type="text" name="wantispam_q" class="wantispam-control wantispam-control-q" value="6.5.3" autocomplete="off" /></div><div class="wantispam-group wantispam-group-e" style="display: none;"> <label>Leave this field empty</label> <input type="text" name="wantispam_e_email_url_website" class="wantispam-control wantispam-control-e" value="" autocomplete="off" /></div></div></form></div><div id="comments" class="entry-comments"></div></div></main></div><div id="secondary" class="sidebar-area"><aside class="sidebar sidebar-wide-top" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><section id="text-28" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-2822762039080737" data-ad-slot="Linoxide_ADX_Blog_Posts_Right1"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><form class="linoxideSearchWidget" itemprop="potentialAction" itemscope="" itemtype="https://schema.org/SearchAction" method="get" action="https://linoxide.com/" role="search"><meta itemprop="target" content="https://linoxide.com/?s={s}"><input itemprop="query-input" type="search" name="s" id="linoxideSearchInput" placeholder="Search Linoxide Tutorials"><input type="submit" value="Search"></form></div></div></section><section id="recent-posts-widget-with-thumbnails-2" class="widget recent-posts-widget-with-thumbnails"><div class="widget-wrap"><div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget"><h2 class="widget-title widgettitle">Latest Giveaways!</h2><ul><li><a href="https://linoxide.com/linux-how-to/install-python-3-7-on-ubuntu-18-04-lts/" target="_blank"><img width="190" height="91" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20190%2091'%3E%3C/svg%3E" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" data-lazy-srcset="https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04.png 713w" data-lazy-sizes="(max-width: 190px) 100vw, 190px" data-lazy-src="https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-190x91.png" /><noscript><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-190x91.png" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/03/install-python3.7-ubuntu-18.04.png 713w" sizes="(max-width: 190px) 100vw, 190px" /></noscript><span class="rpwwt-post-title">Install Python 3.7 on Ubuntu 18.04 LTS</span></a></li><li><a href="https://linoxide.com/linux-how-to/how-to-install-rpm-on-centos/" target="_blank"><img width="190" height="91" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20190%2091'%3E%3C/svg%3E" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" data-lazy-srcset="https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos.png 713w" data-lazy-sizes="(max-width: 190px) 100vw, 190px" data-lazy-src="https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-190x91.png" /><noscript><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-190x91.png" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/02/install-rpm-centos.png 713w" sizes="(max-width: 190px) 100vw, 190px" /></noscript><span class="rpwwt-post-title">How to Install RPM on CentOS</span></a></li><li><a href="https://linoxide.com/linux-how-to/ubuntu-keyboard-shortcuts/" target="_blank"><img width="190" height="91" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20190%2091'%3E%3C/svg%3E" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" data-lazy-srcset="https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts.png 713w" data-lazy-sizes="(max-width: 190px) 100vw, 190px" data-lazy-src="https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-190x91.png" /><noscript><img width="190" height="91" src="https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-190x91.png" class="attachment-home-thumb size-home-thumb wp-post-image" alt="" srcset="https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-190x91.png 190w, https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts-300x143.png 300w, https://linoxide.com/wp-content/uploads/2020/03/ubuntu-keyboard-Shortcuts.png 713w" sizes="(max-width: 190px) 100vw, 190px" /></noscript><span class="rpwwt-post-title">Ubuntu Keyboard Shortcuts that Every User Should Know</span></a></li></ul></div></div></section><section id="text-29" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-2822762039080737" data-ad-slot="Linoxide_ADX_Blog_Posts_Right3"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></section><section id="text-27" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div style="color: #fff; background: #F7BA08; font-size: 18px; padding: 8px;">           Linux Commands Cheat Sheet<a style="color: #194357; width: 100%; display: block; text-align: center; text-decoration: underline; font-size: 18px;" href="https://linoxide.com/linux-command/linux-commands-cheat-sheet/" target="_blank" rel="noopener noreferrer">Download PDF Version</a></div></div></div></section><section id="text-26" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div style="color: #fff; background: #f60; font-size: 18px; padding: 8px;">Beginners Kubernetes Practical Guide<br /> <a style="color: #194357; width: 100%; display: block; text-align: center; text-decoration: underline; font-size: 18px;" href="https://linoxide.com/ebooks/learn-kubernetes-basics-beginners-guide-online/" target="_blank" rel="noopener noreferrer">Download Your Free Ebook</a></div></div></div></section><section id="text-30" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display: inline-block; width: 336px; height: 280px;" data-ad-client="ca-pub-1494089593353074" data-ad-slot="9479741343"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></section><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"> <script async src="https://live.sekindo.com/live/liveView.php?s=99693&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=[WIDTH]&y=[HEIGHT]&vp_content=plembed13c7kqgviytw&subId=[SUBID_ENCODED]"></script> </div></div></section></aside></div></div></div><div class="banner-ad ad-above-footer" style="background-color:#ffffff"><div class="wrap">  <script>window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
ga('create', 'UA-47319559-1', 'auto');
ga('send', 'pageview');</script> <script async src='https://www.google-analytics.com/analytics.js'></script> </div></div><div id="footer-widgets"><div class="wrap"><div class="row"><aside class="sidebar col-md-4 footer-widgets-left"><section id="text-24" class="widget widget_text"><div class="widget-wrap"><h2 class="widget-title widgettitle">About &#038; Contact Pages</h2><div class="textwidget"><div class="helpicon"> <a target="_blank" href="https://linoxide.com/feedback" rel="noopener noreferrer"><span class="icon-tools"></span><br /> Notify Any Errors </a></div><div class="helpicon"> <a target="_blank" href="https://linoxide.com/linoxide-team/" rel="noopener noreferrer"><span class="icon-chat"></span><br /> Meet Our Team </a></div><div class="helpicon"> <a target="_blank" href="https://linoxide.com/contact-us/" rel="noopener noreferrer"><span class="icon-envelope"></span><br /> Provide News &#038; Tips</a></div><div class="helpicon"> <a rel="nofollow noopener noreferrer" class="external" target="_blank" href="https://linoxide.com/ebooks/free-linux-ebooks-beginners/"><span class="icon-gears"></span><br /> Free Linux Ebooks </a></div></div></div></section></aside><aside class="sidebar col-md-4 footer-widgets-center"><section id="socialicons-widget-2" class="widget socialicons"><div class="widget-wrap"><h2 class="widget-title widgettitle">Join Our 16.9K Linux Community</h2><div class="textwidget dark square"><div class="subicons site-icons"> <a data-toggle="tooltip" data-placement="bottom" class="subicon rss" rel="external" title="RSS Feed" href="https://linoxide.com/feed/"><i class="fa fa-rss"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon twitter" rel="external" title="Connect on Twitter" href="https://twitter.com/LinOxide"><i class="fa fa-twitter"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon facebook" rel="external" title="Connect on Facebook" href="https://www.facebook.com/Linoxide"><i class="fa fa-facebook"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon pinterest" rel="external" title="Connect on Pinterest" href="https://www.pinterest.com.au/LinOxide/"><i class="fa fa-pinterest"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon youtube" rel="external" title="Connect on Youtube" href="https://www.youtube.com/channel/UC9y60e21PnE5xmc0PfcKgjw"><i class="fa fa-youtube-play"></i></a></div></div></div></section><section id="text-25" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><p style="font-size: 16px; text-align: center;">Ask &amp; Share &#8211; <a target="_blank" style="text-decoration:underline; color: #12b7d5!important; text-align: center;" href="https://www.facebook.com/groups/LinuxPenguinChatGroup/" rel="noopener noreferrer">Join Our Facebook Community</a></p></div></div></section></aside><aside class="sidebar col-md-4 footer-widgets-right"><section id="text-19" class="widget widget_text"><div class="widget-wrap"><h2 class="widget-title widgettitle">SUBSCRIBE TO FREE NEWSLETTER</h2><div class="textwidget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow"><div class="textwidget"><div class="feedwidgetdiv"><h4>Enjoyed the Read?</h4><p>Don’t miss our next article!</p><div style="text-align: center;"><input name="email" required="required" type="email" placeholder="Enter Your Email *" /> <input class="feedsubmit" type="submit" value="Subscribe" /> <input name="uri" type="hidden" value="linoxideblog" /> <input name="loc" type="hidden" value="en_US" /></div><p style="margin-bottom: 0px;">100% privacy &#8211; We will never spam you</p></div></div></form></div></div></section></aside></div></div></div><footer class="site-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="wrap"><div class="subicons site-icons"> <a data-toggle="tooltip" data-placement="bottom" class="subicon rss" rel="external" title="RSS Feed" href="https://linoxide.com/feed/"><i class="fa fa-rss"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon twitter" rel="external" title="Connect on Twitter" href="https://twitter.com/LinOxide"><i class="fa fa-twitter"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon facebook" rel="external" title="Connect on Facebook" href="https://www.facebook.com/Linoxide"><i class="fa fa-facebook"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon pinterest" rel="external" title="Connect on Pinterest" href="https://www.pinterest.com.au/LinOxide/"><i class="fa fa-pinterest"></i></a><a data-toggle="tooltip" data-placement="bottom" class="subicon youtube" rel="external" title="Connect on Youtube" href="https://www.youtube.com/channel/UC9y60e21PnE5xmc0PfcKgjw"><i class="fa fa-youtube-play"></i></a></div><ul id="footernav" class="footer-nav-menu"><li id="menu-item-16860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16860"><a href="https://linoxide.com/tos/">Terms of Service</a></li><li id="menu-item-16861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16861"><a href="https://linoxide.com/privacy-policy/">PRIVACY</a></li><li id="menu-item-16862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16862"><a href="https://linoxide.com/contact-us/">CONTACT</a></li></ul><div class="site-info hasnav"> Copyright © 2020 BTreme. All rights reserved</div></div></footer></div><style>.entry-meta span.author  span {
	        	  margin-right:0;
	        }
		    #category_post_list_widget-5
		    .widgettitle, #category_post_list_widget-4 .widgettitle, #text-16 .widgettitle, .widget_color_bg_tag_cloud .widgettitle{
		         background: #12b7d5!important;
		             font-size: 16px !important;
				    font-weight: 600 !important;
				    text-transform: uppercase;
				    margin-bottom: 6px !important;

				    text-align: center;
				    padding: 10px;
				    border-bottom: none;

		   }

		  #footer-widgets .post_content {
		   	      border:none;
		   }
		   .fl.newsdesc {
			    border-bottom: 1px solid #cfc7c7;
			    margin-bottom: 10px;
			}
		   #text-16 form {
			    background: #194357;
			    border-radius: 11px;
			}
		 body .fl.newsdesc h2 a:hover{
		 	color:#000!important;
		 }</style><div id="backtotop"><i class="fa fa-angle-up fa-lg"></i></div> <script defer src="https://linoxide.com/wp-content/cache/autoptimize/js/autoptimize_7a10bcc64e88e2a1547c9db07cd16593.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1585820197 -->